Beantwortet

Übertragungsmodul Problem --> Welcher Prozessstarter?


Benutzerebene 2

Moin Community!
 

Seit dem Update auf 22.3.7 haben wir Probleme mit dem Übertragungsmodul. Ist da was bekannt?

Kann mir einer sagen, welcher Prozessstarter dafür zuständig ist?

 

@db_terlebach 

icon

Beste Antwort von Büsra Özkan 10 August 2022, 13:43

Original anzeigen

7 Antworten

Benutzerebene 3

Moin,

Der Prozessstarter heißt “Übertragenmodul (Fulfillment, Übertragen, EDI, XML) “.
Wir nutzen den auch und noch läuft alles wie es soll.

 

Um noch ein paar mehr Details an die Hand zu geben. Wir hatten vorher die Version 21.x laufen.

Vorher hatte das Übertragungsmodul gut funktioniert. Wir verwendet das Modul um EDI Bestellungen zu versenden sobald diese das Flag “EDI” bekommen.

Aktuell ist es so, dass Bestellungen mit dem EDI Flag in “zu Übertragen” angezeigt werden, dann aber nichts weiter passiert.

 

Im Tab “Fehler” ist nichts zu finden.

Hat jemand eine Idee oder einen Lösungsansatz?

 

Gruß

Tomas

@Marcel T. Danke für deine Antwort. Das ist alles sehr merkwürdig bei mir. Aber du scheinst Recht zu haben.

 

Ich habe jetzt stundenlang getestet und verschiedene Accounts angelegt. Mal funktioniert es und mal nicht. Ich kann gar nicht genau fest machen, wieso, weshalb und warum…
Ich glaube ich muss mich da doch nochmal an den Support wenden.

Benutzerebene 6
Abzeichen +3

Hey ihr Lieben, 

erstmal danke für die schnelle Antwort @Marcel T.! Vielen Dank auch für die weiteren Infos, @db_terlebach

Ich habe natürlich auch direkt für dich ein Ticket erstellt. Hier in der Community sollte sich dann auch so asap jemand von unseren Spezialisten melden! :) 

Liebe Grüße und schon Mal ein schönes Wochenende! 😎

@Jonas Müller Ich habe jetzt noch weiter getestet. Mittlerweile hat sich meine Verwirrung bezüglich des Prozessstarters in Luft aufgelöst. Ich habe gesehen, dass jeder der angelegten Accounts nur ein mal die Stunde ausgeführt wird - egal wie oft ich den Prozess starte. Das erklärt wieso meine Tests auf der Staging Umgebung mal funktioniert haben und mal nicht.

Gibt es die Möglichkeit einen Account öfter ausführen zu lassen?

Aber nochmal zum eigentlichen Problem. Ich sehe, dass die Bestellungen in “zu Übertragen” stehen und dort aber nicht weiter verarbeitet werden.


In der Laufzeitanzeige des Prozesses sehe ich, dass es an irgendeiner Stelle einen Fehler gibt. Vielleicht hat das ganze etwas damit zu tun?
 

 

Ich kann leider keinerlei Informationen zu dem Fehler finden. Die Fehler Listen der Accounts sind auch leer. In der Datenbank bin ich auch nicht fündig geworden.

Sentry hat auch nichts mitgeloggt.

 

Ich fische im trüben und hab keine Ahnung mehr, wo ich noch suchen soll.

Eine Sache die mir noch seltsam vorkommt ist folgende Fehlermeldung beim Verbindungstest des Accounts:

 

Ich bin wirklich für jede Hilfe dankbar, da wir auch langsam Druck bekommen EDI wieder zum Laufen zu bekommen.

 

Gruß

 

Tomas

Benutzerebene 4
Abzeichen +1

Hi Tomas,
 
ich benötige ein paar weitere Infos, um dein Problem näher zu überprüfen. Hierfür habe ich dir in einem separaten Ticket geschrieben. Sobald wir zu einer Lösung gekommen sind, poste ich diese natürlich auch hier auf der Community, damit auch andere Kunden davon profitieren können. 😌
 
 
LG
Büsra

Benutzerebene 4
Abzeichen +1

Hi zusammen,

das Problem war in diesem Fall, dass beim Upgraden der PHP Version ein Modul nicht installiert wurde. Das konnten wir herausfinden, indem die Einträge im Log File kontrolliert wurden. Der Log File kann über die URL mit module=logfile aufgerufen werden.

?name=Bildschirmfoto+2022-05-25+um+07.53.57.png

Hier sind öfter mal Fehlermeldung vorhanden, die man aufklappen kann und oft versteckt sich da ein Hinweis. Es lohnt sich also den Log File zu aktivieren und auch bei anderen Problemen einen Blick darauf zu werfen. 😊

 

 

LG Büsra

Antworten