Beantwortet

Versandartenmapping funktioniert nicht


Benutzerebene 1
Abzeichen

Liebe Community,

 

wir sind recht neu mit Xentral unterwegs, haben uns zwar recht gut eingefunden, allerdings will das Versandartmapping nicht funktionieren. In unserem Shopify-Testaccount lege ich eine Bestellung mit bspw. Standard - Versand an:

 

In Xentral habe ich ein Mapping angelegt für die Versandart Standard:

 

Und auch das Versandartenmapping aktiviert:

 

Das interessiert den Auftrag jedoch recht wenig. Nach dem Import wird mir im Auftrag immer die gleiche Versandart angezeigt - scheint so, als nähme Xentral die alphabetisch erste aus der Liste der insgesamt verfügbaren Versandarten, egal ob die gemappt ist oder nicht:

 

 

Was mache ich falsch? Es ist sehr frustrierend...

Herzlichen Dank im Voraus!

icon

Beste Antwort von Fulfiller 22 July 2022, 17:48

Original anzeigen

21 Antworten

Benutzerebene 7
Abzeichen +5

Die Versandarten in den Shop Einstellungen für das Mapping werden durch den Auftragsimport generisch angelegt, wenn noch nicht vorhanden. Das ist sicherer, als selbst Einträge anzulegen, da so sichergestellt ist, dass die Schreibweise aus dem Shop 1:1 übereinstimmt. Wenn “Standard” vom Shop so kommt, ist es merkwürdig, dass dein Mapping nicht greift. War das schon vor dem Auftragsimport komplett angelegt? 

Ich könnte mir noch vorstellen das die Versandart dhlversenden ggf. zu einem Projekt zugeordnet ist und der Shop zu einem anderen Projekt und daher die Versandart nicht automatisch zugeordnet werden kann. 

Benutzerebene 1
Abzeichen

Vielen Dank für deine schnelle Rückmeldung, leider führte sie nicht zum Erfolg.

Ich habe noch einmal alle Versandmappings gelöscht und sie generisch erstellen lassen:

 

Außerdem habe ich die Versandart dem Projekt zugeordnet (vorher bestand keine Zuordnung zu einem Projekt):

 

Die Versandart Spedition ist daher die einzige Versandart, die diesem Projekt überhaupt zugeordnet ist.

Dennoch: Im danach neu erstellten und importierten Auftrag wirkt es sich nicht aus. Da in der Mappingtabelle keine neue Versandart angelegt wird, gehe ich davon aus, dass Xentral die angelegte auch findet. Xentral nutzt sie aber dennoch nicht.

 

 

Benutzerebene 1
Abzeichen

Bonus: Im Versandzentrum erscheinen alle Aufträge als Selbstabholer, also nichtmal als “AAAA Sendcloud 2“ mit dem Sendcloudmodul. 

 

Eine solche Versandart ist nicht eingerichtet. 

Benutzerebene 7
Abzeichen +5

Das Verhalten kann man nicht nachvollziehen. Da scheint was generell nicht zu passen. 

Benutzerebene 6
Abzeichen +3

@Fulfiller habt ihr ggf. Einträge im Versandregeln Modul vorgenommen?

index.php?module=carrierselect&action=list

Ansonsten ist das Verhalten eigentlich nicht wirklich nachzuvollziehen. Ich würde Zahlungsweisen und Versandarten nicht auf Projekte einschließen - das hat manchmal blöde Seiteneffekte. 

Benutzerebene 1
Abzeichen

Nein, wir haben dort keine Einträge. Der Support hat sich das in einer VC auch einmal angesehen, kann es sich auch nicht erklären.

Eigentlich war das Modul meine Hoffnung für einen Workaround. Da es aber laut Community buggy und nicht nutzbar ist, funktioniert dies auch nicht. Alles sehr unbefriedigend.

Benutzerebene 4
Abzeichen

Hallo, habt ihr eine Lösung gefunden?

Ich habe das Problem auch schon seit längerer Zeit, die Versandarten werden nicht richtig gemapped und wenn eine Versandart International durchkommt, wird es mit einem wirren Zahlen/Buchstabencode angelegt.

Ich hab auch schon alles versucht, die Länder mit angegeben, alles nochmal gelöscht etc. ec.

Die ganz untereste Versandart ist die die bei International jetzt durchkommt, das Verhalten gibt es aber schon seit ein paar Versionen, meine auch das schonmal gemeldet zu haben.

LG
danny

 

Benutzerebene 5
Abzeichen +4

Hallo @Fulfiller, du hast im Versandartenmapping dhlversenden für drei verschiedene Shop-Versandarten verwendet.

So kann Xentral alle Aufträge nur auf dhlversenden setzen.

Du musst für unterschiedliche Shopversandarten auch passende Xentral Versandarten anlegen und diese dann mappen. Shopstandard zu Xentralstandard / Shopexpress zu Xentralexpress.

Erst dann bringt das Mapping  der Versandarten in der Shopschnittstelle etwas.

@Daniela Nowak @Fulfiller Sind die Versandarten-Bezeichnungen so auch 1:1 in Shopify?

Worin besteht Unterschied bei International und Standard international? Beide verweisen auch nur auf eine Versandard in Xentral, müssten also auch in Shopify den gleichen Inhalt (Frachtregeln) haben.

Ich kenn mich mit Shopify noch nicht so gut aus, aber mir scheint, dass das Mapping nicht funktioniert und deshalb die neue Versandarten-ID von Shopify nach Xentral gelangt.

Wichtig ist, dass die Shop-Versandartenbezeichnung in der Shopschnittstelle von Xentral auf der Shopseite identisch geschrieben ist. Wir hatten dies bei einer Shopware-Versandart, ein kleiner Tippfehler und das Mapping funktioniert nicht. Xentral wählt dann den ersten Eintrag der Versandartenliste. 

Benutzerebene 4
Abzeichen

Die Versandarten wurden so von shopify übergeben in den Zeiten wenn es mal funktioniert hat (scheinbar scheint sich das von update zu update wieder zu ändern).

International soll mit DPD verschickt werden National mit DHL

Warum 2x international vergeben wurde weiss ich leider auch nicht, in shopify gibt es eigentlich nur 2 Versandarten für die Post, dann noch selbstabholer.

Toll wäre natürlich noch wenn man Gewichte einstellen könnte z. B. bis 4kg DHL danach UPS, aber solche Regeln sind ja leider auch nicht möglich.

Von daher sollte so ein einfaches Mapping ja zumindest mal durchgängig funktionieren. Vielleicht vergleichen wir mal alle unsere Versionsnummern? Ich bin auf der neuesten...

Benutzerebene 1
Abzeichen

@HB3 Danke für deinen Hinweis. Mir ist bewusst, dass so alle Shopversandarten auf dhlversenden mappen. Das Problem ist leider, dass trotzdem nicht dhlversenden gewählt wird. Im Auftrag wird Sendcloud wie beschrieben angezeigt. Im Versandzentrum Selbstabholer, obwohl es diese Versandart nicht gibt.

Die Bezeichnungen sind alle von Xentral selbst angelegt und nicht selbst eingetragen worden. Selbst die Versandart im mapping anzulegen habe ich auch getestet, führt zu keinem anderen Ergebnis.

 

@Daniela Nowak Das Problem mit der internationalen Versandart habe ich auch. In Xentral wird eine lange alphanumerische Zeichenkette angezeigt. 

 

Auch das Versandregeln-modul, welches eigentlich noch viel wichtiger ist, funktioniert nicht. Die Fehler dort sollen angeblich mit der nächsten Version behoben werden. Wir sind auf 22.1.32.

 

Das Status so ist eine Katastrophe. Jeder Auftrag muss händisch noch einmal aufgemacht, überprüft und angepasst werden.

 

 

Benutzerebene 4
Abzeichen

@Fulfiller Ja ist wirklich nervig, dieses Versandmodul kann doch aber auch nicht soviel selbst wenn es fuktioniert oder? Da es kostenpflichtig ist habe ich das glaube ich nur mal ganz kurz getestet.
 

Hast du denn einen Fall aufgemacht mit dem Support?

Benutzerebene 6
Abzeichen +3

Ich denke, man wird hier nicht drumherum kommen, dass ein xentral Mitarbeiter sich das mal in einer TV-Sitzung anschaut und nochmals in einen deep dive geht. Und hier wurde ja auch schon gesagt, mal das komplette Versand-Mapping neu aufzubauen - sprich alles zu löschen und neu zuzuordnen, mit den ersten neuen Aufträgen, aber das hat ja wohl auch nicht geholfen. Das sind einfach viel zu viele komische Sachen die da passieren und normalerweise klappt das Versandarten Mapping bei Shopify recht zuverlässig. 

Benutzerebene 4
Abzeichen

@Christian machst du denn immer updates auf alle neuen Versionen?

Benutzerebene 6
Abzeichen +3

@Christianmachst du denn immer updates auf alle neuen Versionen?

@Daniela Nowak als Partner haben wir meist ein System, dass auf der aktuellen stable läuft und eins das auf beta läuft. Trotzdem würde ich persönlich nach einer gewissen Zeit auf die aktuelle stable wechseln, denn in alte Versionen laufen oft keine Bugfixes mehr rein und größtenteils wurden auch in der neuen stable einige Fehler behoben oder neue Funktionen hinzugefügt. Auf eine Beta würde ich persönlich vermutlich im laufenden Betrieb nicht wechseln - dann eher mit einer Testversion erst einmal probieren, ob es meinen live Betrieb ggf. zu Fehler kommt. Das ist aber meine reine persönliche Meinung. 

Benutzerebene 1
Abzeichen

@Daniela Nowak Ich habe bereits eine Session mit einem Supportmitarbeiter gehabt, es wird wohl noch eine weitere geben. 22.3.3 hat das Problem übrigens nicht behoben.

Benutzerebene 4
Abzeichen

@Fulfiller ok danke halte mich auf dem Laufenden, ich bin nächste Woche eh im Urlaub, vielleicht ist es ja bis dann behoben :D

Benutzerebene 1
Abzeichen

Gab es hierzu bereits Rückmeldung zu deinem Ticket @Fulfiller ?
Wir haben das gleiche Problem. 

 

Danke! 
Lena 

Benutzerebene 1
Abzeichen

Nach der weiteren Session konnte der Fehler seitens Xentral nachvollzogen, aber nicht behoben werden. Ich habe noch ein paar Versuche unternommen, aber bisher gibt es keine Lösung. Zumindest ist eine Fehlkonfiguration von unserer Seite ausgeschlossen worden.

Benutzerebene 3
Abzeichen +1

Hallo,

ich stehe vor dem selben Problem. Bei uns ist es so, dass ich gerne das Lager entlasten will und das Versandartenmapping dazu nutzen möchte, dass der Packer nicht selbstständig wählen muss welcher Absender auf dem Versandlabel stehen soll - das ist immer davon abhängig aus welchem Shop die Bestellung kommt. Nun wollte ich alle Versandarten aus dem Shop zu Xentral mappen und dann die Versandart z.B. GLS Shop XY nennen. Da sind dann 2 Probleme aufgetreten. 1. Das Mapping funktioniert nicht und 2. Der Absender wird nicht automatisch gezogen.

Bei Aufträgen die per Übertragenmodul reinkommen funktioniert es einwandfrei 🤷🏼

Benutzerebene 1
Abzeichen

Ein kurzes Update: Die Lösung ist laut Support bei den Zahlungsweisen nicht auf Barzahlung zu mappen. Ich kann es erst im Laufe der nächsten Woche testen, wollte es hier aber schon einmal teilen:

 

“Hintergrund, warum das Mapping nicht funktioniert hat ist, dass xentral bei einer Barzahlung automatisch eine Abholung der Ware annimmt. Da die Selbstabholer Versandart in deiner Instanz nicht (mehr) vorhanden/deaktiviert ist, wurde auf die erste Versandart (in deinem Fall AAAA Sendcloud) gemapped. Warum im Versandzentrum dann dennoch "selbstabholer" angezeigt wird, kann ich mir nicht erklären aber ich vermute dass hier etwas hard kodiert wurde.
Jedenfalls funktioniert das hinterlegte Mapping bei allen anderen Zahlungsweisen. “

 

Löst es das Problem bei euch?

Benutzerebene 4
Abzeichen

Ist doch eigentlich Blödsinn, vorher hat es ja auch funktioniert, und Barzahlung haben wir schon immer drin...Wie soll ich sonst die Abholaufträge mappen die bar bezahlt werden sollen?

Antworten