Beantwortet

Shopware 6.4


Benutzerebene 1

Wir verwenden zur zeit Xentral 20.3 mit Shopware 6.3 und überlegen, auf Shopware 6.4 zu aktualisieren. Da es in Shopware 6.4 Änderungen an der API gab, bin ich unsicher, ob diese Version mit Xentral zusammen funktioniert.

Hat jemand nähere Informationen darüber, welche Shopware Versionen in welcher Xentral Version unterstützt werden?

icon

Beste Antwort von Agnes Wachinger 5 July 2021, 09:03

Original anzeigen

18 Antworten

Hi Michael,

die Frage habe ich mir leider erst gestellt, nachdem ich das Update vollzogen habe. Schließlich wurde das Shopware Plugin ja bereits für 6.4 released... naja, danach ging einiges nicht mehr, da die API URL nicht mehr stimmte. Musste mir nun erstmal mit Änderung des xentral Source Codes helfen und nun läuft es.

Warte auf Feedback vom zentral Team.

Hallo Michael,

mit der Shopware Version 6.4 ändern sich die API Routen, daher können wir aktuell nur Version 6.3 unterstützen. Das passen wir in den nächsten Wochen an, ein genaues Datum gibt es noch nicht.

Hi Agnes, wieso habt ihr dann den xentral Business Booster so früh für 6.4 released? Das ist schon irgendwie irreführend.

 

Benutzerebene 1

Hallo Agnes,

danke für die Rückmeldung. Shopware 6.4 wird für uns immer wie wichtiger, da viele dringende Features dort umgesetzt wurden.

Gibt es bereits nähere Informationen, wann Showpare 6.4 unterstützt wird? Oder gibt es allenfalls einen Workaround?

Für uns wäre es auch ausgesprochen dringend, dass sich hier was tut. Im Handbuch war die Rede von vier Wochen...?

Gibt es hier einen verlässlichen Zeithorizont?

Laut Changelog wurde die Integration anscheinend erledigt:

  • Merge pull request #1975 from xentral-erp-software-gmbh/ECOM-255-integrate-shopware-6-4-to-21.1 (14.06.2021 rev 8178b57)

und beim aktuellen Stand habe ich auch eine checkbox in der Schnittstellen Konfig:

  • Shop Version >= 6.4.0

aber egal ob mit Haken oder ohne, die Abfrage für neue Aufträge geht an:

/api/v2/search/order

Also die falsche Route.

 

 

 

Benutzerebene 1

@Robert Walther Vielen Dank für die Info - ich habe den Eintrag soeben auch im Changelog gesehen.

@Agnes Wachinger Müsste gemäss dem oben erwähnten Change Shopware >= 6.4 nun offiziell unterstützt werden?

Hallo Community,

wir testen das aktuell mit einem Kunden. Das ging nochmal zurück an die Entwicklung, daher supporten wir aktuell 6.4 immer noch nicht.

darf ich kurz fragen? wie ist denn der Stand? Wir haben für nächste Woche Entwicklerressourcen für Shopware 6.4 gebucht. Müssen wir die absagen oder können wir damit rechnen, dass die Schnittstelle bis dahin funktioniert?

Danke für die Info!

Benutzerebene 1

Ich weiss nicht, ob es offiziell neue Informationen gibt. Ich habe aber vorher nach einem Update nochmals getestet und leider ebenfalls die oben erwähnten Probleme gehabt.

Habe gerade das aktuelle Update 21.1.f53f241 eingespielt.  Bei mir läuft jetzt wieder alles wie vorher. 

Ich habe soeben das Update gezogen und ich bekomme immer noch eine Fehlermeldung.

500RETURN VALUE OF SHOPIMPORTER_SHOPWARE6::GETTAXIDBYRATE() MUST BE OF THE TYPE STRING, NULL RETURNED
 
gibt es jetzt irgendein neues Pflichtfeld, dass unter 6.4 nicht gefüllt sein musste? Vorher hatte ich keine Probleme und habe nichts am Artikel geändert.

Checkbox in der Schnittstelle aktiviert? 

Ja, den Haken hatte ich schon gesetzt und gehofft es würde jetzt gehen.

Hallo Community,

wir haben Ende letzter Woche ein weiteres Update online gestellt. Die Funktionalität von xentral mit Shopware 6.4 ist nun gegeben.

Benutzerebene 1

Hat zufällig jemand seit dem neuesten Xentral Update, das Update auf Shopware 6.4 durchgeführt? 

Funktioniert mittlerweile alles problemlos? Muss nach dem Update etwas umgestellt werden, oder muss etwas vor dem Update vorbereitet werden?

Danke im Voraus für Antworten :)

Benutzerebene 3
Abzeichen

Hallo liebe Community,

seit heute erhalten wir beim Übertragen von Artikel an SW6 die Fehlermeldung "RETURN VALUE OF SHOPIMPORTER_SHOPWARE6::GETTAXIDBYRATE() MUST BE OF THE TYPE STRING, NULL RETURNED", die ein Nutzer vor 4 Monaten bereits hier in den Kommentaren gemeldet hatte.

 

Kurze Info zu den Versionen:

Xentral 21.1.6e3dadb (Home)

Shopware v6.4.5.1 Stable Version

 

Liebe Grüße und hoffe auf Hilfe

Lucas

Guten Morgen,

wir sind sicherheitshalber auf v6.4.1.2 Stable Version geblieben. Dementsprechend haben wir auch bislang keine Probleme. Xentral ist dagegen auf dem neuesten Stand. 

Hat der Shopware_API_Benutzer die nötigen Rechte? In unserem einen Shop hatte er sie damals nicht. Deswegen bekamen wir diese Fehlermeldung im einen Shop, während der andere problemlos lief. 

Gruß + Daumen drücken, dass das Problem bald gelöst istSebastian 

Antworten