Frage

Shopify Artikelexport - Error

  • 23 January 2023
  • 7 Antworten
  • 79 Ansichten

Hallo Community,

Ich versuche ca. 40 (Rest-)Artikel nach Shopify zu exportieren, erhalte aber folgenden Fehler.

Es gab einen Fehler beim Aktualisieren des Artikels im Shop! (error: Unprocessable Entity 'string' must be consistent with the definition's type: 'multi_line_text_field'.)

Alle anderen Artikel aus anderen Datenimporten werden wie erwartet nach Shopify exportiert. Ich kann kein Problem mit den 40 Artikeln feststellen. Ich habe die Artikel aus Artikel-fremdnummern gelöscht und versucht, erneut zu exportieren, ohne Erfolg. Hatte jemand einen ähnlichen Fehler und wie haben Sie ihn behoben? Ich nehme an, dass es sich um ein Datenproblem handelt (Eigenschaft oder Freifeld), aber ich kann die fehlerhaften Daten nicht finden. Hat jemand eine Idee? Thanks!


7 Antworten

Benutzerebene 1

Hallo Triena,

der Fehlermeldung nach könnte es sein daß es das multi_line_text_filed gar nicht gibt im Artikel.

Generell ist es schwer, eine Einschätzung abzugeben, ohne die Datei gesehen und analysiert zu haben.
Gerne können wir dir individuell weiterhelfen melde sich gerne bei  uns Kontakt@onethon.de 

VG

Katharina

Benutzerebene 2
Abzeichen

Hi @Triena Seliger-Gest 

Ich kriege zurzeit auch ähnliche Meldungen bei einem Teil der Produkte, welche ich an Shopify übertrage. Habe das Problem gestern bemerkt. 

Allenfalls ein Bug? Ich verwende 23.0.0

Hast Du eine Lösung gefunden?

@Triena Seliger-Gest und @JohnnyVegas habt ihr zufälligerweise bei den betreffenden Produkten Parameter/Freifelder definiert? Wir haben gerade das gleiche Problem, sobald wir die Freifelder entfernen, läuft wieder alles problemlos. Sind gerade auch etwas ratlos, weil wir an den Freifeldern nichts geändert haben, und auch die zugeordneten Metafelder bei Shopify nicht verändert wurden.

Benutzerebene 3

Moin, 

ich hatte das gleiche Problem heute morgen. Das Produkt wurde aber trotzdem übertragen.

Sieht auf den ersten Blick so aus, als ob der Feldtype nicht richtig definiert wurde.

Lösung habe ich aber leider auch nicht.

Viele Grüße

Felix

@Felix Wessely bei uns auch, allerdings wird nicht alles übertragen, die Produktbilder und Metafelder fehlen nach dem Upload.

Wir können den Fehler dann komischerweise umgehen, wenn die Metafelder des betreffenden Produktes in Shopify händisch gefüllt werden. Übertragen wir dann das Produkt erneut, so wird alles sauber hochgeladen und die Xentral-Metafelder mit den korrekten Werten aus den Xentral-Freifeldern überschrieben.

Es scheint (zumindest bei uns) also irgendein Missverständnis bei Shopify zu geben, wenn die Metafelder noch keine Werte haben und von Xentral aus gefüllt werden sollen.

Benutzerebene 2
Abzeichen

@Triena Seliger-Gest und @JohnnyVegas habt ihr zufälligerweise bei den betreffenden Produkten Parameter/Freifelder definiert? Wir haben gerade das gleiche Problem, sobald wir die Freifelder entfernen, läuft wieder alles problemlos. Sind gerade auch etwas ratlos, weil wir an den Freifeldern nichts geändert haben, und auch die zugeordneten Metafelder bei Shopify nicht verändert wurden.


Hi @leezelukas verwende keine Freifelder. Nur Eigenschaften und diese werden korrekt übertragen und in Shopify als Metafeld angelegt. Bei mir geht einfach das Bild nicht raus...

Benutzerebene 3


Hi @leezelukas verwende keine Freifelder. Nur Eigenschaften und diese werden korrekt übertragen und in Shopify als Metafeld angelegt. Bei mir geht einfach das Bild nicht raus...

Moin @leezelukas 

das stimmt, die Bilder wurden bei uns heute auch nicht übertragen, obwohl der Bildersync aktiviert war.

Viele Grüße

Felix

Antworten